
www.mweda.com 1第四章 单端口网络和多端口网络

5. HFSS工程实例

5.1  HFSS微波无源元件

5.2  HFSS微波天线设计

5.3  HFSS信号完整性设计

5.4 HFSS电磁兼容问题研究



www.mweda.com 2第四章 单端口网络和多端口网络

3.工程实例　

设计目标如下：　

中心频率：910MHz　

带宽：40MHz　

带内反射：<20dB　

带外抑制：在842MHz处>20dB　

采用三腔微带环形谐振器，其耦合矩阵为　


















30764.028205.143523.0
28205.121309.028205.1
43523.028205.130764.0

M （5-1-41）
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1）建立新的工程　

为了方便创建模型，在Tools>Options>HFSSOptions

中将Duplicateboundarieswithgeometry复选框选中，这样

可以使得在复制模型的同时，所设置的边界也一同复制。
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2）设置求解类型　

将求解类型设置为激励求解类型：　

（1）在菜单栏中点击HFSS>SolutionType。　

（2）如图5-1-7所示，在弹出的SolutionType窗口中：　

(a)选择DrivenModal。　

(b)点击OK按钮。　
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图5-1-7设置求解类型
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3）设置模型单位　

（1）在菜单栏中点击3DModeler>Units。　

（2）在弹出的如图5-1-8所示的窗口中设置模型单位，在

此可选择：mm。

图5-1-8设置单位
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4）建立滤波器模型　

（1）首先建立介质基片，建立后的模型如图5-1-9所示。

图5-1-9建立介质基片
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（a）在菜单栏中点击Draw>Box或者在工具栏中点击按

钮 ，这时可以在3D窗口中创建长方体模型。　

（b）在右下角的坐标输入栏中输入长方体的起始点位

置坐标，即　X：-20，Y：-35，Z：0.0　

按回车键结束输入。输入各坐标时，可用Tab键来切换。

（c）输入长方体X、Y、Z三个方向的尺寸，即　

dX：40，dY：70，dZ：-1.27　

按回车键结束坐标输入。　
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（d）在特性（Property）窗口中选择Attribute标签，

将该长方体的名字修改为Substrate。　　

（e）点击Material对应的按钮，在弹出的材料设置窗

口中点击AddMaterial按钮，添加介电常数为10.8的介质，

将其命名为sub。
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（2）建立Ring-1。　

（a）在菜单栏中点击Draw>Rectangle以创建矩形模型。　

（b）在右下角的坐标输入栏中输入起始点位置坐标，即　

X：0.0，Y：0.0，Z：0.0　

按回车键结束输入。　

（c）输入矩形边长，即　

dX：10，dY：-25，dZ：0.0　

按回车键结束输入。
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（d）在特性（Property）窗口中选择Attribute标签，将

该矩形的名字修改为Ring-1。　

（e）在菜单栏中点击Draw>Rectangle。　

（f）在右下角的坐标输入栏中输入起始点位置坐标，即

　

X：1.4，Y：-1.4，Z：0.0　

按回车键结束输入。　

（g）输入矩形边长，即　

dX：7.2，dY：-22.2，dZ：0.0　

按回车键结束输入。
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（h）在特性（Property）窗口中选择Attribute标

签，将该矩形的名字修改为Inner。　

（i）同样地，建立矩形Cut-1，输入的坐标分别为：

X：4.0，Y：-25，Z：0.0　

dX：2.0，dY：1.4，dZ：0.0　

按回车键结束输入。　

（j）用Ring-1将Inner和Cut-1减去，使之成为一个开

口的矩形环。在菜单栏中点击Edit>Select>ByName，在弹

出的窗口中利用Ctrl键选择Ring－1、Inner和Cut－1。
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（k）在菜单栏中点击3DModeler>Boolean>Subtract，

在Subtract窗口中分别做如下设置：　

BlankParts:Ring-1　

ToolParts:Inner，Cut-1　

Clonetoolobjectsbeforesubtract复选框不选　

点击OK按钮结束设置。相减之后的模型如图5-1-10所示。
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图5-1-10建立Ring＿1 
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（3）移动Ring-1。　

（a）将Ring-1沿Y轴作微小的移动。在菜单栏中点击

Edit>Select>ByName，在弹出的窗口中选择Ring-1。　

（b）在菜单栏中点击Edit>Arrange>Move，在坐标输入

栏中输入移动的向量，即　

X：0.0，Y：0.0，Z：0.0　

dX：0.0，dY：-0.9，dZ：0.0　

按回车键结束输入。

（4）创建Ring＿2。
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（a）Ring-2与Ring-1沿X轴对称，因此可以用对称复制操

作创建Ring-2。在菜单栏中点击Edit>Select>ByName，在弹

出的窗口中选择Ring-1。　

（b）在菜单栏中点击Edit>Duplicate>Mirror，输入向

量，即　

X：0.0，Y：0.0，Z：0.0　

dX：0.0，dY：1.0，dZ：0.0　

按回车键结束输入。　

（c）在操作历史树中双击新建的矩形，在特性窗口中重

新将其命名为Ring-2。建立的Ring-2模型如图5-1-11所示。
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图5-1-11建立Ring＿2 
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（5）创建Ring-3。　

（a）在菜单栏中点击Draw>Rectangle。　

（b）在右下角的坐标输入栏中输入起始点位置坐标，
即　

X：0.0，Y：-12.5，Z：0.0　

按回车键结束输入。　

（c）输入矩形边长，即　

dX：-10，dY：25，dZ：0.0　

按回车键结束输入。　

（d）在特性（Property）窗口中选择Attribute标签，
将该矩形的名字修改为Ring-3。
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（e）在菜单栏中点击Draw>Rectangle。　

（f）在右下角的坐标输入栏中输入起始点位置坐标，

即　 X：-1.4，Y：-11.1，Z：0.0　

按回车键结束输入。　

（g）输入矩形边长，即　

dX：-7.2，dY：22.2，dZ：0.0　

按回车键结束输入。　

（h）在特性（Property）窗口中选择Attribute标

签，将该矩形的名字修改为Inner-2。
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（i）建立矩形Cut_2

输入坐标为：

X:0, Y:-0.7, Z:0;

dX:-1.4, Y:1.4, Z:0。
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（j）在菜单栏中点击Edit>Select>ByName，在弹出的窗

口中利用Ctrl键选择Ring-3、Inner-2和Cut-2。

（k）用Ring-3将Inner-2和Cut-2减去，使之成为一个开口

的矩形环。在菜单栏中点击3DModeler>Boolean>Subtract，在

Subtract窗口中做如下设置：　

BlankParts:Ring-3　

ToolParts:Inner-2，Cut-2

Clonetoolobjectsbeforesubtract复选框不选　

点击OK按钮。　



www.mweda.com 22第四章 单端口网络和多端口网络

（6）移动Ring-3。　

移动Ring-3，使之与Ring-1和Ring-2有0.5mm的缝隙。

（a）在菜单栏中点击Edit>Select>ByName，在弹出的

窗口中选择Ring-3。　

（b）在菜单栏中点击Edit>Arrange>Move，在坐标输

入栏中输入移动的向量，即　

X：0.0，Y：0.0，Z：0.0　

dX：-0.5，dY：0.0，dZ：0.0　

按回车键结束输入。建立的模型如图5-1-12所示。
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图5-1-12 建立Ring＿3 
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（7）创建Feedline-1。　

创建滤波器的馈线结构，该馈线由特性阻抗不同的两段

微带传输线组成。　

（a）在菜单栏中点击Draw>Rectangle。　

（b）在右下角的坐标输入栏中输入如下点的坐标：　

X：10.4，Y：-25.9，Z：0.0　

dX：0.4，dY：25，dZ：0.0　

按回车键结束输入。　

（c）创建矩形后，在弹出的特性（Property）窗口中

选择Attribute标签，将该名字修改为F-1。
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（d）在菜单栏中点击Draw>Rectangle。　

（e）在右下角的坐标输入栏中输入如下点的坐标：　

X：10.4，Y：-25.9，Z：0.0　

dX：1，dY：-9.1，dZ：0.0　

按回车键结束输入。　

（f）在弹出的特性（Property）窗口中选择　
Attribute标签，将该名字修改为F-2。

（g）在菜单栏中点击Edit>Select>ByName，在弹出的
窗口中利用Ctrl键选择F-1和F-2。　

（h）在菜单栏中点击3DModeler>Boolean>Unite，在如

图5-1-13所示的历史操作树中，双击新组合的模型F-1，在特
性窗口中将其重新命名为Feedline-1。
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图5-1-13历史操作树
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（8）创建Feedline-2。　

同样地，Feedline-2与Feedline-1沿X轴对称，因此也可以

通过对称复制操作来创建。　

（a）在菜单栏中点击Edit>Select>ByName，在弹出的窗

口中选择Feedline-1。　

（b）在菜单栏中点击Edit>Duplicate>Mirror，输入向

量，即 　

X：0.0，Y：0.0，Z：0.0　

dX：0.0，dY：1.0，dZ：0.0　

按回车键结束输入。

（c）在操作历史树中双击新建的馈线，在特性窗口中将
其重新命名为Feedline-2。创建后的模型如图5-1-14所示。
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图5-1-14建立Feeline



www.mweda.com 29第四章 单端口网络和多端口网络

（ 9 ） 组 合 Ring-1 、 Ring-2 、 Ring-3 、 Feedline-1 和

Feedline-2。　

将上述各步骤中创建的Ring-1、Ring-2、Ring-3、Feedline-1和

Feedline-2组合成一个模型。　

（a）在菜单栏中点击Edit>Select>ByName，在弹出的窗口

中选择Ring-1、Ring-2、Ring-3、Feedline-1和Feedline-2。　

（b）在菜单栏中点击3DModeler>Boolean>Unite。　

（c）在操作历史树中双击组合模型，在特性窗口中将其重

新命名为Trace。
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5）创建端口　

微带滤波器采用集总端口激励，因此需要首先创建供设

置端口用的矩形，该矩形连接了馈线与地板。　

（1）创建port_1。　

（a）在菜单栏中点击3DModeler>GridPlane>XZ。　

（b）在菜单栏中点击Draw>Rectangle，在坐标输入栏

中输入如下坐标：　

X：10.4，Y：-35，Z：0.0　

dX：1.0，dY：0.0，dZ：-1.27　

按回车键结束输入。　
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（c）将其命名为port-1。　

（d）在菜单栏中点击Edit>Select>ByName，在弹出的窗
口中选择port-1。　

（e）在菜单栏中点击

HFSS>Excitations>Assign>LumpedPort，在LumpedPort窗口的

General标签中，将该端口命名为p1，然后点击Next。

（f）在Modes标签的IntegrationLine中点击None，选择

NewLine，在坐标栏中输入如下坐标：　

X：10.9，Y：-35，Z：-1.27　

dX：0.0，dY：0.0，dZ：1.27　

按回车键结束输入。接着点击Next按钮直到结束。
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（2）创建port-2。　

（a）在菜单栏中点击Edit>Select>ByName，在弹出的窗
口中选择port-1。port-2与port-1也以X轴对称，因此可以利
用对称复制操作创建。　

（b）在菜单栏中点击Edit>Duplicate>Mirror，输入向
量，即　

X：0.0，Y：0.0，Z：0.0　

dX：0.0，dY：1.0，dZ：0.0　

按回车键结束输入。　

（c）在操作历史树中双击新建的端口，在特性窗口中将
其重新命名为port-2。由于在建立工程的第一步已经设置了
复制边界选项，因此在复制创建port-2之后，端口上设置的
激励也一同复制了。
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6）创建Air　

（1）在菜单栏中点击Draw>Box或者在工具栏中点击按钮。

（2）在右下角的坐标输入栏中输入长方体的起始点位置
坐标，即　

X：-70，Y：-90，Z：-50　

按回车键结束输入。输入各坐标时，可用Tab键来切换。　

（3）输入长方体X、Y、Z三个方向的尺寸，即　

dX：140，dY：180，dZ：100　

按回车键结束输入。　

（4）在特性（Property）窗口中选择Attribute标签，
将该长方体的名字修改为Air。
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7）设置边界条件　

边界条件包括理想金属边界条件和辐射边界条件。滤波

器的导带部分、介质基片下底面地板要设置为理想金属边界。

设置辐射边界是为了截断求解区域。　

（1）设置理想金属边界条件。　

（a）在菜单栏中点击Edit>Select>ByName，在弹出的窗

口中选择Trace。　

（b）在菜单栏中点击

HFSS>Boundaries>Assign>PerfectE，在弹出的对话框中将其

命名为Perf-Trace，点击OK按钮。　
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（c）在菜单栏中点击Edit>Select>Faces，这时已经

将鼠标所选设置为选择模型的表面了。然后点击ByName，

选择Substrate，选择其下底面，选择的时候在3D窗口中

进行观察，确保选择到下底面。　

（d）在菜单栏中点击

HFSS>Boundaries>Assign>PerfectE，在弹出的对话框中

将其命名为Perf＿Ground，点击OK按钮。
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（2）设置辐射边界条件。　

（a）在菜单栏中点击Edit>Select>Objects，然后点击

ByName，选择Air。　

（b）在菜单栏中点击

HFSS>Boundaries>Assign>Radiation，在弹出的对话框中点

击OK结束。
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8）为该问题设置求解频率及扫频范围　

（1）设置求解频率。　

（a）在菜单栏中点击

HFSS>AnalysisSetup>AddSolutionSetup。　

（b）在求解设置窗口中做如下设置：　

SolutionFrequency:910MHz　

MaximumNumberofPasses:15　

MaximumDeltaSperPass:0.02 

（c）点击OK按钮。
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（2）设置扫频。　

（a）在菜单栏中点击HFSS>AnalysisSetup>AddSweep。　

（b）选择Setup1，点击OK。　

（c）在扫频设置窗口中做如下设置：　

SweepType:Fast　

FrequencySetupType:LinearCount　

Start:700MHz　

Stop:1100MHz　

Count:501 

（d）将SaveField复选框选中，点击OK按钮。
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9）保存工程　

在菜单栏中点击File>SaveAs，在弹出的窗口中将该工

程命名为hfss-3couple，并选择路径保存。
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10）后处理操作　

在仿真计算结束后，查看滤波器的S参数。　

（1）点击菜单栏HFSS>Result>CreateReport。　

（2）在创建报告窗口中做如下设置：　

ReportType:ModalSParameters　

DisplayType:Rectangle　

点击OK按钮。
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（3）在Trace窗口中做如下设置：　

Solution:Setup1:Sweep1　

Domain:Sweep　

点击Y标签，选择：Category:Sparameter；

Quantity:S(p1，p1)、S(p2，p1)；Function:dB，然后点

击AddTrace按钮。　

最后点击Done按钮完成设置。反射系数和传输系数曲

线如图5-1-15所示。
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图5-1-15滤波器的S参数曲线
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5.1.3源-负载耦合的交叉耦合滤波器的设计　
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1.设计实例　

设计目标如下：　

中心频率：3.3GHz　

相对带宽：0.02　

带内回波损耗：20dB　

阻带最小衰减：25dB　

采用两腔耦合谐振器，并引入源与负载之间的耦合，
其耦合矩阵为

























03557.1004.0
3557.101027.20
01027.203557.1
04.003557.10

M （5-1-57）
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1）建立新的工程　

为了方便创建模型，在Tools>Options>HFSSOptions中

将Duplicateboundarieswithgeometry复选框选中，这样可

以使得在复制模型的同时，所设置的边界也一同复制。　

2）设置求解类型　

将求解类型设置为激励求解类型。　

（1）在菜单栏中点击HFSS>SolutionType。　

（2）如图5-1-19所示，在弹出的　Solution　Type窗
口中：　

（a）选择DrivenModal。　

（b）点击OK按钮。



www.mweda.com 46第四章 单端口网络和多端口网络

图5-1-19设置求解类型
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3)设置模型单位　

（1）在菜单栏中点击3DModeler>　Units。　　

（2）在图5-1-20中设置模型单位：在此选择mm。

图5-1-20设置单位
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4)建立滤波器模型　

（1）建立介质基片。　

（a）在菜单栏中点击Draw>Box或者在工具栏中点击按

钮，创建长方体模型。　

（b）在右下角的坐标输入栏中输入长方体的起始点位

置坐标，即　

X：-5.5，Y：-8，Z：0.0　

按回车键结束输入。输入各坐标时，可用Tab键来切换。
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（c）输入长方体X、Y、Z三个方向的尺寸，即　

dX：11，dY：16，dZ：-0.5　

按回车键结束输入。　

（d）在特性（Property）窗口中选择Attribute标

签，将该长方体的名字修改为Substrate。　　

（e）点击Material后面的按钮，将材料设置为Al2-
03-ceramic。　

（f）点击Color后面的Edit按钮，将颜色设置为绿

色，点击OK按钮结束设置。创建的介质基片模型如图5-1-
21所示。
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图5-1-21建立的介质基片模型
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（2）建立Ring-1。　

（a）在菜单栏中点击Draw>RegularPolygon，建立多边形
模型。　

（b）在右下角的坐标输入栏中输入中心点位置坐标，即　

X：0.0，Y：0.0，Z：0.0　

按回车键结束输入。　

（c）输入半径向量，即　

dX：3.8683，dY：0.0，dZ：0.0　

按回车键结束输入。　

（d）在弹出的Segmentnumber窗口中将多边形边数改为6。
　



www.mweda.com 52第四章 单端口网络和多端口网络

（f）在菜单栏中点击Draw>RegularPolygon。　

（g）在右下角的坐标输入栏中输入中心点位置坐标，即

　

X：0.0，Y：0.0，Z：0.0　

按回车键结束输入。　

（h）输入半径向量，即　

dX：2.1362，dY：0.0，dZ：0.0　

按回车键结束输入。
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（i）在弹出的Segmentnumber窗口中将多边形边数改为6。

　

（j）在特性（Property）窗口中选择Attribute标签，将

该正六边形的名字修改为Inner。　

（k）在菜单栏中点击Edit>Select>ByName，在弹出的窗口

中利用Ctrl键选择Ring-1和Inner。
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（l）用模型Ring-1将Inner减去，使之成为一个正六

边形环。在菜单栏中点击3DModeler>Boolean>Subtract，

在Subtract窗口中做如下设置：　

BlankParts:Ring-1　

ToolParts:Inner　

Clonetoolobjectsbeforesubtract复选框不选。　

点击OK按钮确认设置。　

相减之后的模型如图5-1-22所示。
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图5-1-22建立Ring＿1 
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（3）移动Ring-1。　

将Ring-1沿Y轴负方向移动，如图5-1-23所示。

图5-1-23移动Ring-1 
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（a）在菜单栏中点击Edit>Select>ByName，在弹出的

窗口选择Ring-1。　

（b）在菜单栏中点击Edit>Arrange>Move，在坐标输入

栏中输入移动的向量，即　

X：0.0，Y：0.0，Z：0.0　

dX：0.0，dY：-3.8683mm*sin(pi/3)-0.14555mm，dZ：

0.0　

按回车键结束输入。　
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（c）建立一个小的矩形，供Ring-1相减，使Ring-1成

为一个开口环。在菜单栏中点击Draw>Rectangle，在坐标

输入栏中输入：　

X：-0.346，Y：-8，Z：0.0　

dX：0.692，dY：4.0，dZ：0　

按回车键结束输入。



www.mweda.com 59第四章 单端口网络和多端口网络

（d）将其命名为Cut-1，同时选中Ring-1和Cut-1，在

菜单栏中点击3DModeler>Boolean>Subtract，在Subtract

窗口中做如下设置：　

BlankParts:Ring-1　

ToolParts:Cut-1　

Clonetoolobjectsbeforesubtract复选框不选　

点击OK按钮确认设置。



www.mweda.com 60第四章 单端口网络和多端口网络

（4）创建Ring-2。　

（a）创建Ring-2模型，由于其与Ring-1以X轴对称，

因此可以通过镜像复制操作创建。在菜单栏中点击

Edit>Select>ByName，在弹出的窗口中选择Ring-1。　

（b）在菜单栏中点击Edit>Duplicate>Mirror，输入

向量，即　

X：0.0，Y：0.0，Z：0.0　

dX：0.0，dY：1.0，dZ：0.0　

按回车键结束输入。
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（c）在操作历史树中双击新建的多边形，在特性窗口

中将其重新命名为Ring-2，如图5-1-24所示。

图5-1-24创建Ring-2 
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（5）创建Feedline-1。　

（a）这里我们用折线来创建一个多边形。在创建折线

时，一旦折线闭合，则其会自动封闭成为一个面模型。在

菜单栏中点击Draw>Line。　
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（b）在右下角的坐标输入栏中输入如下点的坐标：　

X：1.5302，Y：-8.0，Z：0.0　

X：1.5302，Y：-7.437，Z：0.0　

X：2.2778，Y：-7.437，Z：0.0　

X：4.5556，Y：-3.4917，Z：0.0　

X：2.5665，Y：-0.04639，Z：0.0　

X：1.9892，Y：-0.04639，Z：0.0 
X：3.9783，Y：-3.4917，Z：0.0　
X：1.9891，Y：-6.937，Z：0.0　
X：0.5302，Y：-6.937，Z：0.0　
X：0.5302，Y：-8.0，Z：0.0　
X：1.5302，Y：-8.0，Z：0.0 

按回车键结束输入。
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（c）在Property（特征）窗口中选择　Attribute　

标签，将该名字修改为Feedline-1。　

创建后的模型如图5-1-25所示。　
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图5-1-25建立Feedline－1 
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（6）创建Feedline-2。　

（a）同样地，我们将Feedline-1以X轴作镜像复制创建

Feedline-2。在菜单栏中点击Edit>Select>ByName，在弹出

的窗口中选择Feedline-1。

（b）在菜单栏中点击Edit>Duplicate>Mirror，输入向
量，即　

X：0.0，Y：0.0，Z：0.0　

dX：0.0，dY：1.0，dZ：0.0　

按回车键结束输入。　

（c）在操作历史树中双击新建的馈线，在特性窗口中
将其重新命名为Feedline-2，如图5-1-26所示。
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图5-1-26建立Feedline-2 
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（7）组合Ring-1、Ring-2、Feedline-1和Feedline-2。

（a）在菜单栏中点击Edit>Select>ByName，在弹出的窗

口中选择Ring-1、Ring-2、Feedline-1和Feedline-2。

（b）在菜单栏中点击3DModeler>Boolean>Unite。　

（c）在操作历史树中双击组合模型，在特性窗口中将其

重新命名为Trace。
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5）创建端口　

（1）为滤波器创建激励端口矩形，端口矩形位于馈线

的起始端和地板之间。首先创建port-1。　

（a）在菜单栏中点击3DModeler>GridPlane>XZ。　

（b）在菜单栏中点击Draw>Rectangle，在坐标输入栏

中输入以下坐标：　

X：0.5302，Y：-8.0，Z：0.0　

dX：1.0，dY：0.0，dZ：-0.5　

按回车键结束输入。　

（c）将其命名为port-1。
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（d）在菜单栏中点击Edit>Select>ByName，在弹出的

窗口中选择port-1。　

（e）在菜单栏中点击

HFSS>Excitations>Assign>LumpedPort，在LumpedPort窗

口的General标签中，将该端口命名为p1，点击Next。　

（f）在Modes标签中的IntegrationLine中点击None，

选择NewLine，在坐标栏中输入以下点的坐标：　

X：1.0302，Y：-8.0，Z：-0.5　

dX：0.0，dY：0.0，dZ：0.5　

按回车键结束输入。接着点击Next按钮直到结束。
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（2）创建port-2。　

（a）在菜单栏中点击Edit>Select>ByName，在弹出的

窗口中选择port-1。　

（b）在菜单栏中点击Edit>Duplicate>Mirror，输入

向量，即　

X：0.0，Y：0.0，Z：0.0　

dX：0.0，dY：1.0，dZ：0.0　

按回车键结束输入。　

（c）在操作历史树中双击新建的馈线，在特性窗口中

将其重新命名为port-2。



www.mweda.com 72第四章 单端口网络和多端口网络

6）创建Air　

创建辐射边界的长方体Air，用以截断计算区域。　

（1）在菜单栏中点击Draw>Box或者在工具栏中点击按钮。

（2）在右下角的坐标输入栏中输入长方体的起始点位置坐
标，即　

X：-15，Y：-15，Z：-1　

按回车键结束输入。输入各坐标时，可用Tab键来切换。

（3）输入长方体X、Y、Z三个方向的尺寸，即　

dX：30，dY：30，dZ：12　

按回车键结束输入。　

（4）在特性（Property）窗口中选择Attribute标签，将该
长方体的名字修改为Air。
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7）设置边界条件　

（1）设置理想金属边界条件。将滤波器的导带部分和
介质基片的底部设置为理想金属边界条件。　

（a）在菜单栏中点击Edit>Select>ByName，在弹出的
窗口中选择Trace。　

（b）在菜单栏中点击
HFSS>Boundaries>Assign>PerfectE，在弹出的对话框中将
其命名为Perf-Trace，点击OK结束。　

（c）在菜单栏中点击Edit>Select>Faces，设置为选
择表面。然后点击ByName，选择Substrate，选择其下底面。

（d）在菜单栏中点击
HFSS>Boundaries>Assign>PerfectE，在弹出的对话框中将
其命名为Perf-Ground，点击OK结束设置。
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（2）设置辐射边界条件。

将Air的各个外表面设置为辐射边界。　

（a）在菜单栏中点击Edit>Select>Objects，然后点

击ByName，选择Air。　

（b）在菜单栏中点击

HFSS>Boundaries>Assign>Radiation，在弹出的对话框中

点击OK结束。
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8）为该问题设置求解频率及扫频范围　

为该问题设置求解频率与扫频范围，求解的中心频率
为3.3GHz，扫频范围为2.6～4.5GHz。　

（1）设置求解频率。　

（a）在菜单栏中点击
HFSS>AnalysisSetup>AddSolutionSetup。　

（b）在求解设置窗口中做如下设置：　

SolutionFrequency:3.3GHz　

MaximumNumberofPasses:15　

MaximumDeltaSperPass:0.02　

（c）点击OK按钮确认设置。
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（2）设置扫频。　

（a）在菜单栏中点击HFSS>AnalysisSetup>AddSweep。　

（b）选择Setup1，点击OK按钮确认设置。　

（c）在扫频设置窗口中做如下设置：　

SweepType:Fast　

FrequencySetupType:LinearCount　

Start:2.6GHz　

Stop:4.5GHz　

Count:501　

（d）将SaveField复选框选中，点击OK按钮确认设置。
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9）保存工程　

在菜单栏中点击File>SaveAs，在弹出的窗口中将该工

程命名为hfss-2couple，并选择路径保存。
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10）后处理操作　

（1）点击菜单栏HFSS>Result>CreateReport。　

（2）在创建报告窗口中做如下设置：　

Report Type:ModalSParameters　

Display Type:Rectangle　

点击OK按钮。



www.mweda.com 79第四章 单端口网络和多端口网络

（3）在Trace窗口中做如下设置：　

Solution:Setup1:Sweep1　

Domain:Sweep　

点 击 Y 标 签 ， 选 择 S 参 数 中 的 S11 和 S21 ， 即

Category:Sparameter ； Quantity:S(p1 ， p1) 、 S(p2 ，

p1)；Function:dB，然后点击AddTrace按钮。　

最后点击Done按钮完成创建。反射系数和传输系数曲

线如图5-1-27所示。
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图5-1-27滤波器的S参数曲线
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HFSS 中文视频培训课程套装 

国内最全面和专业的 HFSS 培训教程套装，包含 5 套视频教程

和 2 本教材，李明洋老师讲解；结合最新工程案例，视频操作

演示，让 HFSS 学习不再难。购买套装更可超值赠送 3 个月免

费学习答疑，让您花最少的成本，以最快的速度自学掌握

HFSS… 【点击浏览详情】 

 两周学会 HFSS —— 中文视频教程 

李明洋主讲，视频同步操作演示，直观易学。课程从零讲起，通过两周的课程学习，可以

帮助您快速入门、自学掌握 HFSS，真正做到让 HFSS 学习不再难…【点击浏览详情】 

 HFSS 微波器件仿真分析实例 —— 中文视频教程 

HFSS 进阶培训课程，中文视频，通过十个 HFSS 仿真设计工程应用实例，带您更深入学

习 HFSS 的实际应用，掌握 HFSS 高级设置和应用技巧…【点击浏览详情】 

 HFSS 天线设计入门 —— 中文视频教程 

HFSS 是天线设计的王者，该教程全面解析了天线的基础知识、HFSS 天线设计流程和详

细操作设置，让 HFSS 天线设计不再难…【点击浏览详情】 

 PCB 天线设计和 HFSS 仿真分析实例 —— 中文视频教程 

详细讲解了 PCB 天线的工作原理和设计方法、如何使用 HFSS 来设计分析 PCB 天线，

以及如何借助于 Smith 圆图工作来调试天线的匹配电路，改善天线性能…【点击浏览详情】 
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微波射频测量仪器培训课程套装合集 
 

搞射频微波，不会仪器操作怎么行！矢量网络分析仪、频谱仪、

示波器、信号源是微波射频工程师最常用的测量仪器。该培训

套装集合了直观的视频培训教程和详尽的图书教材，旨在帮助

您快速熟悉和精通矢网、频谱仪、示波器等仪器的操作…【点

击浏览详情】 

 

 

 Agilent ADS 学习培训课程套装 

 

国内最全面和权威的ADS 培训教程，详细讲解了ADS 在微波射频电路、

通信系统和电磁仿真设计方面的应用。课程是由具有多年 ADS 使用经

验的资深专家讲解，结合工程实例，直观易学；能让您在最短的时间内

学会 ADS，并把 ADS 真正应用到研发工作中去… 【点击浏览详情】 
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